Installation

We recommend that you start with the provided all-in-one download that bundles hyperModel with Eclipse and all required dependencies. That download also includes example Eclipse workspaces and models to get you started. See Downloads page.

If you wish to install hyperModel features into your copy of Eclipse, follow this common installation guide that applies to all platforms.

  • Verify that Java JDK 1.6 or later is installed on your workstation and is used to run Eclipse
  • Download and unzip Eclipse 3.7 or later. Recommend the recent Eclipse Kepler 4.3.1.
  • Start the Eclipse IDE (run eclipse.exe on Windows, Eclipse.app on Mac OSX)
  • Select menu item: Help > Install New Software…
  • Click Add… a new repository
  • Press Finish

You can download a single ZIP file containing example project workspaces and models using this link.


Important: Follow these extra steps when installing hyperModel on Mac OSX and Linux:

hyperModel requires GraphViz libraries to layout dynamic class diagrams (“dynagrams”). This is a platform-specific binary and only the Windows version of GraphViz is bundled with hyperModel plug-ins. You must download and install the latest Mac OSX or Linux build for your distro from the GraphViz download page.

The GraphViz binary executable, named “dot”, must be on the system PATH that is used to run Eclipse. With recent distributions this path should be configured by default. After this is installed and configured, you should be able to display hyperModel class diagrams!