Downloads

If you want a single all-in-one download that contains Eclipse Kepler (4.3.1) platform, hyperModel, and editors for XSD and XML, then you can get it here:

After downloading and unpacking the ZIP, open the “eclipse” sub-folder and run eclipse.exe on Windows, Eclipse.app on Mac OSX. This package is pre-configured with one or more example workspaces that you can select in the Workspace Launcher dialog. These workspaces include projects and models that illustrate current hyperModel features.

You must be running Java JDK version 1.6 or greater. You can check this by opening a command window and typing:

java -version

Or, see additional instructions to install hyperModel plug-ins into your existing Eclipse platform (version 3.7 or greater).


Important: Follow these extra steps when installing hyperModel on Mac OSX and Linux:

hyperModel requires GraphViz libraries to layout dynamic class diagrams (“dynagrams”). This is a platform-specific binary and only the Windows version of GraphViz is bundled with hyperModel plug-ins. You must download and install the latest Mac OSX or Linux build for your distro from the GraphViz download page.

The GraphViz binary executable, named “dot”, must be on the system PATH that is used to run Eclipse. With recent distributions this path should be configured by default. After this is installed and configured, you should be able to display hyperModel class diagrams!